When attempting to insert the Confluence Federated Search Web Part in a Sharepoint Page, you receive an Unknown Error

When attempting to insert the Confluence Federated Search Web Part in a Sharepoint Page, you receive an Unknown Error

Problem

When attempting to insert the Confluence Federated Search Web Part, you receive an "Unknown Error" during the configuration of the Web Part and cannot insert it:

ERROR: Unexpected Error Unable to perform the requested action. Please check your SharePoint and Confluence log for more details.

In newer versions of the Legacy Sharepoint Connector, you may also receive the following message as the details for the error:

The error message reported was: There was an exception in the Database. Please retry your operation and if the problem persists, contact an administrator.

Symptoms

The result sources in the configuration for the Web Part are empty, despite the result sources being configured in Central Administration.

Diagnosis

You must examine your SharePoint Logs to look for the specific database error message. Typically, the account used by the search application (or by Sharepoint) doesn't have permission to log into the Sharepoint Search database. An example log:

System.Data.SqlClient.SqlException (0x80131904): Cannot open database "<database-name>" requested by the login. The login failed. Login failed for user '<username>'.

Cause

The user account specified does not have permission to log into the database specified.

Resolution

The user account listed in the error message must be granted access to the database that was specified. See this MSDN Article for more information.

Related articles