After upgrading the SharePoint Plugin in Confluence, it is no longer possible to connect from SharePoint to Confluence

Symptoms

When attempting to connect from Legacy SharePoint Connector for Confluence (for example, when using a Confluence Web Part or performing a test connection from the Confluence Settings administration screen), the connection fails and an error message like one of the following is displayed:

ERROR: Unable to load spaces or pages from Confluence Unable to perform requested action

Unable to connect to Confluence.

An error message and exception stack-trace similar to one of these messages appears in the SharePoint ULS log:

07/30/2012 12:47:06.34     w3wp (0x1F4E8)                              0x1C8D8    [Atlassian Confluence]            WebPartError                      CSIz    Exception    
Atlassian.Confluence.SharePoint.WebServices.LicenceCheckFailedException: Unable to connect to Confluence 
  ---> System.Web.Services.Protocols.SoapException: Tried to invoke method public abstract boolean com.atlassian.confluence.extra.sharepoint.licensing.LicenceVerificationPublic.isLicenseValid() with arguments . 
       The arguments do not match the signature.; nested exception is:   java.lang.IllegalArgumentException: java.lang.ClassCastException@f45aa92     
         at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
         at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)     
         at Atlassian.Confluence.SharePoint.ConfluenceLicenseWebService.License     
w3wp.exe (0x1728) 0x0B98	[Atlassian Confluence] WebPartError 1129531770	Unexpected 
System.Web.Services.Protocols.SoapException: No such operation 'hasViewPermissionById' at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) 
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) 
at Atlassian.Confluence.SharePoint.ConfluencePermissionCheckerWebService.PermissionCheckerService.hasViewPermissionById(String in0, Int64 in1, String in2) 
at Atlassian.Confluence.SharePoint.WebServices.Internal.PermissionChecker.HasViewPermission(Int64 pageId) 
at Atlassian.Confluence.SharePoint.Services.Internal.PageRenderer.RenderPage(String webPartId, String spaceKey, Int64 pageId, Boolean showMetadata, Boolean showAttachmen...	0224719c-08d4-427c-901a-c2ed28f883b1

Cause

This is caused by an incompatibility between the Legacy SharePoint Connector for Confluence and the Confluence Remote API where the old version of the SharePoint Plugin is not completely disconnected from the Remote API when the new version of the Legacy SharePoint Connector for Confluence is installed. This prevents any remote services provided by the new version of the Legacy SharePoint Connector for Confluence from being accessed via the Confluence Remote API.

Resolution

This problem can be resolved by restarting your Confluence server.

There is no content with the specified labels