Test connection from SharePoint to Confluence fails with License error

Problem

When testing the connection from SharePoint Central Administration, the error stacktrace displayed contains the class Internal.LicenceChecker.IsLicenceValid:


Solutions

There are three reasons for that: SharePoint can not connect to Confluence, the Add-on is not installed or the license is invalid. To check the possibilites, please run the following tests:

1. SharePoint can not connect to Confluence or add-on is not installed

Please make sure, that you can connect to Confluence from every SharePoint Server (warning)

To test the connection, please call the URL http://<confluence-url>/rpc/soap-axis/isSPLicenseValid?wsdl

You should receive a response like this:

 

If you do not see this xml result from every SharePoint Server, please make sure that the connection to Confluence is not blocked by a proxy or firewall. Please make sure, that you have installed the solution on the Confluence side as well!

2. The license is invalid

If you receive the result displayed above, please download the SOAP UI tool and install this on every SharePoint server.

After that, please run the tool and complete the following steps:

  1. Click on SOAP and create a new SOAP call:


  2.  Add https://<confluenc-url>/rpc/soap-axis/isSPLicenseValid?wsdl and click OK


  3. expand the tree on the left and double click on Request


  4. At the bottom of the main panel click on Auth and add a new Authorization
        

  5. Choose between NTLM and Basic Auth in the window
     

  6. Add your credentials and hit the green play button at the top left
     
  7. On the right you should see a request similar to this:

    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
       <soapenv:Body>
          <ns1:isLicenseValidResponse soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:ns1="http://licensing.sharepoint.extra.confluence.atlassian.com">
             <isLicenseValidReturn xsi:type="xsd:boolean">true</isLicenseValidReturn>
          </ns1:isLicenseValidResponse>
       </soapenv:Body>
    </soapenv:Envelope>

    Where the important part is the answer of the request: 

    <isLicenseValidReturn xsi:type="xsd:boolean">true</isLicenseValidReturn>

    If this is displayed your license is correct and you should not have any problems.

 

 

There is no content with the specified labels